Logseq et seq.

I think I screwed up associating logseq with a new repo “commentsPlus”. I did not notice that the primary branch is named “main”, not “master”.

So logseq is associated as an app with some repo on a non-existent master branch. Is there some way to find it and clean it up? Maybe remove the app association?

I am a bit lost here.

Checking this now…

(fyi, the default branch on github is now the less-oppressive-language “main” instead of the older default “master”. more background: https://github.com/github/renaming; also, search if you want more context.)

1 Like

@anderbill, it looks to me like it’s working. (I created a “Hello, world.” bullet, and it checked in.)

Just use “https://github.com/OpenGlobalMind/commentsPlus” for the repo, and “main” (where it defaults to “master”) for the branch when Logseq asks, and I think you’ll be good to go.

Also, no “master” branch got created, so I don’t think there’s any cleanup to do for that.

Hmm, I stomped around more and created a couple of other pages (hello, contents?), while trying to figure out the “Contents” and “Recent” affordances. (Not that I meant to create pages.) I thought “Recent” was “Recent Pages”, but now I think it’s recently viewed. I don’t know what Contents is yet.

I don’t like that there are separate /journals and /pages directories; I’m used to Stroll using tags instead of folders. (So in Stroll, “Journal” is a tag, not a folder.)

Logseq has potential, though…

BTW, Joe, I will be angry with you (for like 200 milliseconds) if I end up falling in love with Logseq so soon after falling in love with Stroll. After being angry, though, I would be very thankful. (And I would have to try Org-mode again!)

Another piece of the puzzle for Bill’s experience.

Checking my inbox (after playing with Logseq and the repo), I saw that I got an email notification from Github, “Integration Installation Request / @band requests you to install Logseq for OpenGlobalMind.”

I’m one of several “Owners” of the org; Bill is a “Member”. (A separate discussion could be had about who should be “Owner” and “Member”; I advocate everyone being “Owner”, but I won’t make that change unilaterally.)

So anyway, when I tried Logseq and the repo, It Just Worked, because I’m an Owner. When Bill tried it, it stopped, waiting for an Owner to approve the installation request.

I think my using it installed it for everybody. The request was also still pending (? github bug ?), so I approved that, too. https://github.com/organizations/OpenGlobalMind/settings/installations/13027129

Works for me after going Avitar → All repos → Add another repo. (https://github.com/OpenGlobalMind/commentsPlus, main)

Tags are spelled like :shortcodes: :sunny:

D’oh, I could not find “Add another repo” to play with my own. Thank you!

:+1: #winning

I’ll pick this up tomorrow. Had a pleasant afternoon in puppy training lessons and enjoying some wonderful Central Texas weather.

I am looking forward to trying to co-author or -mangle a collection of paragraphs.

I did pick this up this morning and as Joe mentioned, I clobbered something. Never a dull day in the software lab. :grimacing:

Wow. Have any of you looked at what shows up in a web-browser at this url (once you have associated your github id and logseq and the OpenGlobalMind/commentsPlus repository):

The pages render as filled with repeating entries of the same text. I have not counted the number of repeats, but it is many.

To paraphrase the internet these days: “What is happening?”

Imma gonna look at the files in github directly, but this seems to be a real mess. Of course it could just be my browser.

woo hoo. we are having fun now.

In my case the content looks pretty innocuous:

Thursday morning, 19 November.
[Nit question: how did you and pete create the pages joe and pete?]

Joe, I see what you see on one of my computers.

On the other one, however, I see this:

Can we move the logsec and any other discussions about specific repositories to their own forum thread so others can find this thread and understand how to sign up more easily?

yes we can do that. one topic per repo? or one topic about, say, ‘specific information repository practice’?

thoughts?

Of course we can! That said, I’m going to take add a further distraction and say: Discourse would be quite nice if it was a bit more obvious how to move threads around. Shouldn’t the whole thread on Logseq (and this comment) be easily transplantable into a new thread? Maybe that feature exists for admins…? But not as far as I can see for normal users.

That ability seems to be available to admins. But I have not tried to do it. Yet.

Maybe put all these topics under “Tools”?

There may be a bit of churn before certain Topic names settle down.

FYI, I moved the Logseq stuff out of the GitHub topic to this shiny new Logseq topic.

Thanks Bentley for the nudge.

Joe, Bill, splitting/moving topics is admin (and moderator, I hope)-specific, and will soon be handled by our newly-forming Moderation Team.

Joe, let us know if you’d like to be on the Moderation Team! :slight_smile:

1 Like

I would not recommend that, simply because the permissions are too high, which leaves the door open to destructive/disgruntled people to do damage. I’m not sure how hard that’d be to undo, but it’s best not to make the temptation available.

Today I noticed that OGM logseq account seems to contain a new journal page for every day, starting on Nov 17, 2020. The journal pages from Nov 21 - Nov 24 only contain a link to themselves; otherwise they are empty.

Does logseq just generate a daily journal page on its own? Is it “spooky action from a server?” Or as people now say on social media “What. Is. Happening?”

1 Like